Restoring Heahkit IT-17 Tube Tester


I acquired quite a bit of old test equipments lately and some of them are based on old vacuum tubes. Most of the time during the restoration process, I am able to get them working without the need of the tube tester. So, a tube tester is on my wish list but it’s not a high priority.

Out of a blue, I stumbled up on a Craigslist listing of 10+ test equipments at really good deal. The piece that I am really interested in buying was the Heathkit IT-17, the rest are nice too but I have no use for them at the moment.

The seller listed it pretty early in the morning, so the chance of it still available when I saw the ad was pretty slim. So, I decided contacted him late in the night anyway.

Early next morning, I got a response back and they are still available. I was so elated when I heard the news. I immediately arranged the time to drop by and drove 50+ miles to Oxnard to pick them up. While I was there he also offered to sell me a box of tubes at really good price.

The Heathkit IT-17

The unit was really an ugly duckling and disgustingly dirty when I pull it out of the box. The back cover is dirty and the paint are peeling. The good thing is that the front panel is still in pretty good shape.

IMG_8862 IMG_8856IMG_8763 IMG_8762 IMG_8761 IMG_8760

Restoring

With the case opened, I quickly examined all the soldering join and looking for burned components. Everything looks good. I went ahead and replaced all bad carbon resistors that are out of tolerance and cleaned all switches and pots with contact cleaner.

I initially followed the IT-3117 instructions, since I can’t find the original IT-17 manual anywhere on the Internet. The only thing I found was the IT-17 schematic and the two are quite similar in design. I proceeded to check the continuity from the switch to all the pins on each socket, they are all good. The filament voltage, however, it is really off and the line test is off-center but the unit is functional.

Testing

With the tube tester semi functional, I decided to give it a test run. With a box of unknown condition tubes at hand, I tried to test some of them. After going through 1/4 tubes in the box I got 2/3 of the tubes are bad and 1/3 are good.

With 2/3 bad tubes start piling up, I started to question the tube tester functionality because who would keep a bunches of bad tubes???

Manual Testing

I decided to do manual testing on 6L6 which was tested bad earlier.

  1. Connected pin 2 and 7 to external power supply the filament is glowing nicely at 6.3 DC. So, the filament is fine.
  2. When connected to the socket on the test tube. The filament is not glowing at all, 0V is measured between 2 and 7.
  3. When 6L6 is not installed, there is 6.3V between pin 2 and 7.
  4. I decided to plug 6L6 tube back in and use the alligator jumper wire and connect pin 2 and 7 to corresponding wire on the switch bank. The filament start glowing nicely. This confirm the socket is making clean contact, but the wiring is possibly bad.
  5. Measuring the resistant from the switch to pin 2, the wire has 50+ Ohm?? Note to self – Don’t trust the continuity beep!!!
  6. After some tracing, it appears that the original builder missed one solder join on one of socket. After fixing that the 6L6 filament start glowing again and the tube tested fine now.

Calibrating Tube Tester

All original instructions assumed that all parts are new and working to spec. So, some of these assumptions are no longer valid since the meter is old and not that accurate. This is true at least in my case, when the meter is zeroed, the reading are way off.

I have to come up with alternative way of calibrating it and ensuring that the tube tester result are some what usable.

Calibrating Line Test Indicator

  1. With no tube in any of the socket
  2. Set all switch to center position, then set A to bottom
  3. Set the filament to 110
  4. Connect a voltmeter black lead on pin 1 and connect red lead on any other pin so we can read the filament voltage. This is important, since the during line voltage adjustment, the meter is connected to 110V tap on the filament winding. At 110V the meter should be reading 50 or .5mA. If not check the 1K and 75K resistor and make sure they are within tolerance.
  5. Turn set line until the filament voltage reading is 110V RMS. Cut a piece of electrical tape in triangle shape and tape it to set line dial to mark this position. This is the correct line voltage for use with the tube tester.
  6. When set line voltage is properly adjusted, the filament voltage reading should be 110V. At this point the meter should be reading exactly 50 or .5mA. This is assuming that the 1K, 75K and your meter are good. If 1K and 75K are good but the meter is not at 50, the meter reading is off. In that case,insert an amp meter in series with the panel meter to get the correct reading, it should be around .5mA. Then adjust the panel meter so that it’s indicating the same reading by turning the zero adjust screw on the panel meter. Once that is done, your set line switch and meter is properly calibrated to show proper line voltage. NOTE don’t adjust the mechanical zero from now on it will screw up the reading.
  7. Next insert a known good tube and set the tube tester accordingly. Then the plate control is adjusted so that the meter is reading from 0 to 100, the measured value from amp meter still inserted in series with the panel meter is recorded at each point to produce a table and chart.
  8. From now on, after testing using the original instructions. Take the reading and use the table to map it to actual value in mA or multiply that by 100 to get % scale.

IT-17_meter_adj

If you find this information helpful and would like to see more. Please support my future project.

Advertisements